[AndroidStudio]をバージョンアップしたらgladleでエラーが出るようになった件

Android Studioを更新したら次のエラーが出るようになりました。

11:17   Gradle sync failed: The version of Gradle you are using (Gradle distribution 'https://services.gradle.org/distributions/gradle-3.3-all.zip') does not support the ModelBuilder API. Support for this is available in Gradle 1.2 and all later versions.

Gradleが原因であることは明らかなため、動作が確認できていたバージョンに戻しました。

次のファイルを編集します。

[プロジェクトルート]/gradle/wrapper/gradle-wrapper.properties
- distributionUrl=https\://services.gradle.org/distributions/gradle-3.3-all.zip
+ distributionUrl=https\://services.gradle.org/distributions/gradle-2.2-all.zip

上記変更の後、メニューから 「Tools > Android > Sync Projext with Gradle Files」 を実行するとまた動くようになりました。